iOS Header/Library Search Paths, and Custom Plist aren't in XCode Project

projucer
ios
#1

I’m trying to create an XCode project for iOS. The projucer creates the project but none of the items in the topic title are copied into the project. I have several entries in Header Search Paths and Extra Library Search Paths, but those don’t appear in the XCode build settings. I tried adding -I and -L flags to Extra Compiler Flags and Extra Linker Flags, but that didn’t work (those don’t seem to get copied either). My Custom Plist entry also doesn’t make it into the plist file. I grepped though all the files in the project and couldn’t find any of my custom entries. Also used the Linux and MacOS versions of the Projucer, neither work.
Every other project seems to export without any problems (MacOSX, Linux Makefile, Visual Studio and Android). Does anyone have any idea why the Projucer isn’t creating an iOS project with my custom settings?

#2

What kind of Projucer project (GUI Application, Console Application, Static Library, Dynamic Library, or Audio Plug-in) are you dealing with?
Not all project types are supported on iOS, and that could explain why Projucer skips applying your custom settings.

#3

It’s a GUI Application. BTW, when I added an entry to Header
Search Paths in global settings, that did get inserted into the
project.

  I might try deleting and recreating the iOS exporter in the

Projucer and seeing if that helps.

#4

I deleted the iOS exporter (and the iOS build directory) and recreated it and this fixed it (everything’s being inserted into the project). Two directories were being created, however, (“iOS” and “iOS_1”) and only iOS was showing in the list of exporters… So I opened the .jucer file in an editor and just deleted the iOS_1 section. Simple solution, but I hope it helps someone.