Issue notarizing standalone (MacOS - microphone access)

I’m using c-lion to sign and notarize a plugin in MacOS, there is no problem with plug-in formats but there is an issue with Standalone version. I cannot generate a signed and notarized standalone version of the plugin with microphone access prompt displayed.

If I do codesign -s WITHOUT –options=runtime the notarization IS NOT successful but microphone access prompt IS displayed.
If I do codesign -s WITH –options=runtime the notarization IS successful but microphone access prompt IS NOT displayed.

Here is my part of my cmakelist settings, I tried a lot of things but nothing can solve this.

juce_add_plugin(
            ... (irrelevant code for this issue)
            PLIST_TO_MERGE "<plist>
            <dict>
            <key>NSAppTransportSecurity</key>
            <dict>
            <key>NSAllowsLocalNetworking</key><true/>
            <key>NSMicrophoneUsageDescription</key>
            <string>This plug-in requires access to the Microphone!</string>
            <key>com.apple.security.device.audio-input</key><true/>
            </dict>
            </dict>
            </plist>"
            MICROPHONE_PERMISSION_ENABLED TRUE
            MICROPHONE_PERMISSION_TEXT "This app needs access to your audio interface"
            HARDENED_RUNTIME_ENABLED TRUE
            HARDENED_RUNTIME_OPTIONS com.apple.security.device.audio-input
            )

Any help will be appreciated!

I solved it, if anyone is interested my solution was apply the steps of the last post of this link: Qt application is not requesting m… | Apple Developer Forums