Issue With Android Tutorial and Android Studio 3.0

android

#1

Hi All,
I am trying to get up and running with android studio 3.0 and Juce, and I have hit a few issues that I haven’t found mentioned in the forum. As I am new to android development, could anyone with experience please point me in the correct direction to find fixes?

My first problem is that the ''save and open in IDE" button is greyed out and inactive. I am using the latest version of JUCE master, and a freshly built projucer. As the sdk and ndk path are in ‘custom’ folder locations as opposed to the default set by android studio, could this be linked to the cause of the projucer not recognising android studio? The pojucer recognises the various versions of VS I have just fine.

The second problem is that if I just open the project through Android Studio, I get hit with an error suggesting that the flavour dimension definitions are being called in a way that is no longer supported or has changed. The warning states that ‘all flavours must used a named flavourdimension’. I see these as ‘debug’ and ‘release’ in the boiler plate… While I recognise Google might like to shake things up on a regular basis, is this a hang-over from the previous problem I described, or is it just that google have changed the way something is done? If so, can anyone guide me on their best fix, before I resort to https://developer.android.com/studio/build/gradle-plugin-3-0-0-migration.html#flavor_dimensions

Many Thanks,
Simon


#2

For anyone else who is new to android development and comes across the second problem, the fix that has worked for me is that I went into the app gradle script that the build error points you to.

In the section where productFlavours are defined, in the first line i defined a single ‘flavorDimensions’ called ‘tier’. In the subsequent boilerplate definitions of ‘debug_’ and ‘release_’ flavours I have added ’ dimension “tier” ’ as the first line of each definition. This has allowed me to build and run the basic GUI application with ‘hello world’ in the emulator. I will try on hardware later this evening.


#3

In the Global Search Paths window accessible from the Projucer menu , have you specified the custom Android SDK and NDK locations of your machine?


#4

Yes, absolutely.
I have attempted to follow this fantastic tutorial.


#5

I was not able to solve the first problem too (I had Android Studio 3.0 installed on D) but after reinstalling in the default location (C:\Program Files\Android\Android Studio) I can now run everything from Projucer.

As goes for this ‘flavorDimension’ issue it is even a simpler workaround. Edit ‘build.gradle’ script like below (just add: flavorDimensions “default”):

apply plugin: 'com.android.application'

android {
    flavorDimensions "default"
    ...
}

I tested it with the emulator and hardware, seems ok.

I think it is related with 3.0 version, after installing Android Studio on C I got the same error.