Issue with Audio Unit on 10.11

We should not have too much hope for a fix for this. 10.11 and 10.12 are not supported by Apple anymore.

Edit: There are also no new security updates for 10.11 / 10.12. So it’s even a security risk to use that os versions. Time moves fast in apple world…

I’m still on catalina, so i’m next soon :grimacing:

Thanks for the information. That’s not a fix. But good to hear that at least they don’t install the faulty framework anymore.

I’m not sure if we can expect that every user can follow the instructions to delete the framework. An official update would be a much better solution.

I will try it and send it to a user. I wonder how the feedback will be…

Apple Feedback assistant told me this

After reviewing your feedback, we have some additional information for you, or some additional information, or action is necessary for this issue: 

You'll need to download the newer version of MobileDevice, which should be offered through Software Update.

So I wonder if they have pushed a new version. Does anybody with a 10.11 can confirm this ?

Thanks !


Please ask the users of affected machines to use Software Update. This should download a new framework.

Has anyone done this? We just instructed a user to and there were no updates available in Software Update.


@LinuxVST do you know what “User Experience (UX) is”?

You keep insisting that your approach is a solution. It is NOT, because it is not USABLE, it gives users a very BAD user experience. And in a commercial world, that can kill your products and thus your business.

What is your drive to keep posting this?

Do you want people to slap you on the shoulder and say “That’s brilliant!” ?

I guess a lot of us are thinking “That’s brilliant, but it’s also f*cking madness to try with my users/clients”:

but the users has to boot in Recovery and Disable SIP
then Restart & Run the Installer
then Reboot again in Recovery to Re-Enable SIP

You are really impressing with your technical skills, but they will never be applied, unless embedded in a “solution” that respects end-users and is designed for a good User Experience.

1 Like

Can anybody confirm the existence of this update?
Is there any official info from apple about this issue?

1 Like

@goodhertz dis-confimed the update above.
As I wouldn’t count on Apple to fix this (I don’t think that it’s in their DNA to update their old systems, not nowadays at least), my best recommendation to users is the workaround I suggested above, which worked for 2/3 above (and @RolandMR if you could elaborate or send me your attempt I could perhaps try investigate why it didn’t work for you).
As for a user who is affected, most plugins seem to be affected, I think that it would best be in the form of a script that a user could run on all their plugins to work-around the problem for all of them.

Somehow there is maximum ambiguity right now. Did apple say there is a an update to fix this or not?

If there is any chance to reach an official solution I would find that better.
Furthermore, I am concerned that this solution create new problems.

Do you have any more information?
What is the version number of this new framework?
What is the version number of the defective framework?
Can you ask apple for more details?

Maybe @mfritze can help us too.

1 Like

I meant to say that according to a recent comment, Issue with Audio Unit on 10.11 - #93 by goodhertz, there are no updates available, in contrast to the Apple quote in a comment above it, Issue with Audio Unit on 10.11 - #91 by otristan

Yes I know. I was asking if anybody has an update and not if a specific one has no update :wink:

1 Like

The information we have received from Apple is the same as that provided via Feedback Assistant and quoted in this thread.

We are following up.

1 Like

Asking Apple to fix anything in 10.11 is a complete waste of time.

As @kunz posted: Catalina and Big Sur (10.15 and 11) are still getting security fixes, while Monterey is the only OS that gets any non-security fixes. Ventura is the one where the work is put into right now. If a user has an issue with an older version of macOS, the answer always is: macOS updates are free, so please update to the latest version of macOS, which is supported on your Mac. For Monterey these includes all Macs from 2015 onwards and an older MacMini and the older Mac Pro, so it covers the past 7+ years of supported hardware.

Logic Pro and MainStage traditionally only support the current version of macOS and the last free update of the previous one (sometimes when a new version of macOS was just released, there is an overlap and for a short time there are 3 supported versions of macOS). GarageBand only supports the current version of macOS.

If you really need something to work on 10.11 you are on your own and have to hack it together yourself.


Can’t remember exactly why it wouldn’t work, but the library was still failing to load. I can try it again, but we’ve bumped or minimum version to 10.13 so putting any more time into this is low priority.

I was under impression that we discussing an issue, which was introduced by an automatic update, which happens, when an iOS device is plugged to an older macOS computer. Or am I wrong?

This update causes things that worked before to no longer work.

An the fix ist to update to a newer macOS release, which basically means, that my customer should buy new hardware?

Or I should give advices to my customer to hack its system with uncertain outcome.

What should I tell my customer?


This is completely understandable, yet, 10.11 and 10.12 were working perfectly fine until a new iOS/iPad update introduced this issue.


Apple’s communication is a little ambiguous.

If this is an issue mediated via connecting an iOS device to iTunes, is there a software update available for the corresponding iOS device? If so, does connecting an updated device to iTunes fix things?

Some details on this, including a fix that solely relies on official Apple downloads

TL;DR is Apple is still pushing the bad framework, but a working one for at least 10.11 (El Capitan) systems can be reinstalled via iTunes 12.8.2, after the bad one is deleted. Users will have to disable SIP to swap out the framework, and have to continue to avoid further updates that will reinstall the bad framework. Not ideal by any means, but it IS a way to for users to get their legacy systems functioning again without resorting to bypasses of the verification process or installing frameworks modified by third parties, or depending on individually patched plug-ins from every vendor.

The easiest way to identify the version # of the installed framework is to issue the following command in the Terminal:

/usr/libexec/PlistBuddy -c "Print :CFBundleVersion" /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/Current/Resources/version.plist

If the command fails rather than printing a version #, see footnote (1).

Known BAD versions incompatible with OSX 10.11.6 El Capitan:

  • 1369.

Known GOOD versions compatible with OSX 10.11.6 El Capitan:

  • 988.
  • 988.222.1

As of 22 August 2022, Apple Software Update is still pushing the BAD 1369. version of MobileDevice.framework on 10.11.6 El Capitan systems.

The ideal workaround is to recover a version of MobileDevice framework from a backup of the target computer prior to the bad update. Unfortunately that is often not possible.

For systems running OSX 10.11.6 (El Capitan) the following workaround has been verified relying solely on official Apple downloads. Unfortunately, it requires the user to temporarily disable SIP. There does not appear to be a way to avoid this, since the faulty framework is located in a System folder and SIP must be disabled to remove or replace it.

Steps to disable SIP:

  • Shut down computer
  • Press and hold cmd-R while starting the computer
  • Release the cmd and ‘R’ keys when the progress bar appears
  • Select a preferred language if prompted
  • Select Utilities->Terminal from main menu
  • Enter the command:
csrutil disable
  • Restart computer

Now remove the faulty MobileDevice framework:

  • From the finder, navigate to the folder /System/Library/PrivateFrameworks/
  • Move the MobileDevice.framework folder to the trash

Install a known good MobileDevice framework via the iTunes 12.8.2 installer, which is available via a link on this official Apple page (not the main download button, but the inline link below that reads "10.11 and 10.12 users download iTunes 12.8.2 here.”):

  • Download the iTunes.dmg disk image
  • Double-click the “Install iTunes.pkg” installer in that disk image

Verify that the MobileDevice framework is now the correct version (988.222.1) by entering this command in the Terminal:

/usr/libexec/PlistBuddy -c "Print :CFBundleVersion" /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/Current/Resources/version.plist

Turn off Software Updates

  • Select System Preferences->App Store
  • Uncheck “Automatically check for updates"

Re-enable SIP:

  • Shut down computer
  • Press and hold cmd-R while starting the computer
  • Release the cmd and ‘R’ keys when the progress bar appears
  • Select a preferred language if prompted
  • Select Utilities->Terminal from main menu
  • Enter the command:
csrutil enable
  • Restart computer

At this point, a properly compatible MobileDevice framework should now be installed but any plug-ins which previously failed verification will need to be re-verified in order to allow their use in Logic.


DO NOT INSTALL ANY FURTHER SECURITY OR DEVICE UPDATES ON THAT VERSION OF OSX or a faulty MobileDevice framework is likely to be installed again.


(1) If PlistBuddy is not installed on the target computer or cannot be run for some reason, the version can be determined by visual inspection of the complete plist file by:

more /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/Current/Resources/version.plist`

Which will result in an output like this:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
 <plist version="1.0">

Thanks for the update.

It seems like we are completely left alone with that and we can’t rely on Apple to do anything.

So it looks like that only the AU-Plugin Hosts need this framework?!, would at be an option to change Projucer to only include the framework if its really necessary? We are still being contacted by customers who are experiencing this problem.

@reuk @t0m

I won’t go away. Expect to get these messages for years. It also breaks older builds of your software that have been running fine for years. Even if you patch ProJucer (like I posted somewhere above) to exclude CoreAudioKit, only your newest builds will work - and they might not even load on old machines if you happened to raise system requirements in the meantime :confused: .
Now it’s probably just a reality of being a plugin developer… along with the regular stream of “My laptop got stolen…”, “I misplaced my credentials…” and “Help! Urgent! [insert random product] does not run correctly in [insert very obscure unknown host] and I need to finish my potentially grammy-winning album tomorrow”.