Issues entering text into texteditor on Android


#1

Hi, textedit exhibits strange behaviour on Android. When typing, the letters do not appear in the text edit, but only into the autocomplete bar on the keyboard. When you select a word on the keyboard, the first letter is entered into the textedit only. Repeating this process enters 1 letter at a time only.

This can be seen in the concertina panels section of the Juce Demo.


#2

bump


#3

Hi @leehu. What is the Android OS version you are using? Also, what is your device and what are your soft keyboard settings on it?


#4

Hi. Android 7.0, Asus Zenpad, and not sure what my soft keyboard settings are as I wasn’t aware of that :wink: I’ll have a look now - should I be looking for anything in particular?


#5

I can’t really see anything in the keyboard settings that would affect text input in this way - I’ve tried changing a few things but has no effect


#6

Ok, thanks. On the devices and emulators I have I was unable to see the autocomplete bar on soft keyboard when entering text into TextEditors in the demo app, even though I had completions enabled in keyboard settings. Maybe @fabian has access to a device which exhibits the issue.


#7

ah, ok - i’ll see if I can find someway to turn it off…


#8

confirmed that the issue disappears if I turn off the autocomplete ribbon


#9

Ok, thanks.


#10

@leehu Can you check which keyboard you are using (in settings -> input methods)? Is it Gboard or Keyboard (AOSP)? For me, Keyboard (AOSP) does not support autocomplete and Gboard does not offer autocomplete inside of JUCE applications (no idea how we managed to do that though).


#11

ZenUI keyboard - must be a custom ASUS offering I guess. i should be able to install Gboard and try that


#12

Gboard is fine but as you say has no autocomplete ribbon, so that does appear to be the issue, the way the autocomplete ribbon is interacting


#13

It’s so they can collect even more or your data :yum:.

It does, just not in JUCE apps. We must have some kind of way of telling the Gboard keyboard that we don’t want autocomplete - and the ZenUI keyboard doesn’t seem to respect this.


#14

ok, got ya.