juce_getIAAHostIcon link error


#1

Hi,
I’m trying to use the PluginHostType for my iOS App to display if my App is connected to IAA and also a host icon button.
IAA was working as long as I didn’t try to use the getHostIcon, switchToHostApplication and isInterAppAudioConnected method.
Now I have the following link error:

"Undefined symbols for architecture arm64:
_ “juce_getIAAHostIcon(int)”, referenced from:_
_ juce::PluginHostType::getHostIcon(int) const in libUPiper.a(include_juce_audio_plugin_client_utils.o)_
_ “juce_switchToHostApplication()”, referenced from:_
_ juce::PluginHostType::switchToHostApplication() const in libUPiper.a(include_juce_audio_plugin_client_utils.o)_
_ “juce_isInterAppAudioConnected()”, referenced from:_
_ juce::PluginHostType::isInterAppAudioConnected() const in libUPiper.a(include_juce_audio_plugin_client_utils.o)_
_ juce::PluginHostType::getHostIcon(int) const in libUPiper.a(include_juce_audio_plugin_client_utils.o)_
ld: symbol(s) not found for architecture arm64"

My juce version is 5.1.2. Those methods are part of the juce_StandaloneFilterApp that worked so far. Is it some issue with the “extern” definition in the PluginHostType class ?

Thanks for your help


#2

Yep, we’ve already fixed this - please try the develop branch from GitHub. I’ll get the fix onto the 5.2 master branch shortly.


#3

Great, thank you for this very quick answer


#4

The fix is now available on the master branch:

https://github.com/WeAreROLI/JUCE/commit/d654e442aa3a003428eafbb66ce7b63d69f29702


#5

Hi, Juce 5.2.0, still getting this error.

EDIT:
I used download version (not Git one), I inserted manually the diff from your commit (master branch) and now it works. So maybe download version on JUCE site is not synced with Master Branch? Or am I missing something?

Thank you


#6

Yes, that’s right. The download from the JUCE website is only updated each time we release a new version, so the master branch can be ahead.