Juce over VNC


#1

Hi,

None of the Juce apps work for me over VNC under Linux (Linux server, windows client). They come up then freeze whenever you do anything. Everything is fine working on the Linux box itself.

I doubt this is a Juce problem. im wondering if there’s a VNC setting i need to check.

anyone else had this?

– hugh.


#2

As a newbie to JUCE, I have a similar problem, not over VNC, but over ssh.

I wrote a simple test program. It compiled and ran fine locally on my Linux box (RHEL, kernel 2.6.18-194.el5, gcc 4.5.3).
However, when I tried to run it remotely by ssh -X, I got some problem.
The window was shown correctly and I can move it by dragging the title bar.
However, when I tried to resize the window, it did not repaint. It did take effect though. So I could still drag the title bar and move it, and when I clicked the location where the close-window button was supposed to be after the resizing, I could close the window. The problem is it did not repain/refresh.
What’s wrong?

Any input/advice will be appreciated. Thanks.


#3

Under linux resize works slightly strangely. Some of my apps that work fine under Windows simply freeze under Linux because they get flooded with resize events whenever i move.

perhaps this is not always consistent and perhaps this is exacerbated under VNC/ssh etc.

?

– hugh.


#4

Might this help: http://www.rawmaterialsoftware.com/viewtopic.php?f=5&t=6502#p58768


#5

@grebneke, setting JUCE_USE_XINERAMA and JUCE_USE_XSHM to 0 fixed my problem.

The resizing was a little slow over SSH, but it worked. :smiley:

Thanks a lot!

P.S. Is it possible to show only the window frame instead of repainting the entire window continuously while resizing?