Juce plugins not seen in Kore 2?


#1

Hello,

The jucedemoplugin and my own are not recognized by the host NI Kore 2.
I remember I had it working at some point, but at the moment, they’re just not seen both AU & VST. Maybe it’s a king of .plist brace stuff that is touchy ?

Note : I can see juceDemoPlugin.vst being ‘scanned’ but after that it don’t appear in the plugin list.

Thanks !

Salvator


#2

Changing target type property from TDMw to BNDL (or alter the content of /Library/Audio/Plug-Ins/VST/JuceDemoPlugin.vst/Contents/PkgInfo
from ‘TDMwPTul’ into ‘BNDLPTul’ ), made the plugin appears into KORE 2.

I don’t know how this will affect Protools though…

Salvator


#3

Oh for god’s sake, supporting all these hosts is driving me mad! That’s the only one I’ve heard of so far that actually bothers to check the bundle type, but that messes up the whole idea that you can just rename the bundle to make it work with different APIs.

Changing it to BNDL will definitely stop it working in PT.

Maybe there’s a cunning shell script that we could create, as a post-build step, that would copy the bundle to the different plugin folders, but also patch the .plist file appropriately…?


#4

Courage ! Not much more and IMHO the 1.5 master tip is going to be golden !

I could try to write such script, but actually, PT 8 have no issue loading my plugin even after changing to BNDL, clean build etc… I have not tried on 7.4 though.

EDIT : here’s a simple script

-- replace text in PkgInfo of plugin's .dpm /#!/bin/csh /usr/bin/sed -e 's/BNDLPTul/TDMwPTul/g' "/Library/Application Support/Digidesign/Plug-Ins/$PRODUCT_NAME.dpm/Contents/PkgInfo" > "/PkgInfo" #!/bin/bash mv "/PkgInfo" "/Library/Application Support/Digidesign/Plug-Ins/$PRODUCT_NAME.dpm/Contents/PkgInfo"
Note : it work as far modifying the PkgInfo, but not the .plist.
Would that be enough ?

Thanks !

Salvator


#5

Ah! Good… I’ve just tried it in PT7.4, and that’s also ok with BNDL. Problem solved!


#6

So it seemed to work when it was BNDL, but when I tried the script to put it back to TDMw, I had PT complaining when loading the plugin ,as if it was damaged… I’ve not been able to isolate the reason and it was randam; Maybe it’s that mismatch between .plist and PkgInfo…

So I finally feel more comforable to keep TMDwPTul as before, and rather edit the PkgInfo of the .vst instead since, after all, it’s just to please KORE 2.

So i add a post build script phase :

#!/bin/csh /usr/bin/sed -e 's/TDMwPTul/BNDLPTul/g' "/Library/Audio/Plug-Ins/VST/${PRODUCT_NAME}.vst/Contents/PkgInfo" > "/PkgInfo" #!/bin/bash mv "/PkgInfo" "/Library/Audio/Plug-Ins/VST/${PRODUCT_NAME}.vst/Contents/PkgInfo"
I tried that modified vst in Cubase, Tracktion, Reaper, Live,Peak, MAXMSP and they all were fine, as if nothing changed (I tried to clear vst cache etc…) and KORE was happy too !

Thoughts ?
For me, problem solved indeed ! :smiley:

Thanks,

Salvator


#7

I’m a little puzzled - I can’t persuade that sed command to work for me - it just seems to fail to match the string for some reason…