Labels and ComboBox Text not Visible in Win 64Bit


#1

Hi together

Sorry for that many posts i currently make… Have the tip from yesterday, but its not a new problem. I compiled my juce plugin in 64bit on Windows and tested it in cubase 5 64 bit. The whole plugin works, except that i miss the label and combo box text. Works in 32 bit.

Thats how i set up the combo box:

addAndMakeVisible(comboBox = new ComboBox(T("ComboBox"))); comboBox->setBounds(x, y, width, 20); comboBox->setColour(ComboBox::backgroundColourId, Colour::greyLevel(0.2f)); comboBox->setColour(ComboBox::textColourId, Colour::greyLevel(1.0f)); comboBox->setColour(ComboBox::buttonColourId, Colour((juce::uint8)8, (juce::uint8)11, (juce::uint8)58, 0.0f)); comboBox->setColour(ComboBox::arrowColourId, Colour((juce::uint8)8, (juce::uint8)11, (juce::uint8)58, 0.0f)); comboBox->setSelectedId((int)ownerFilter->getParameter(parameter), true); comboBox->addListener (this); comboBox->addItem(T("Off"),1); comboBox->addItem(T("Filter"),2); comboBox->addItem(T("Osc1"),3); comboBox->addItem(T("Osc2"),4);

Do i have to set a font or something? Any help is welcome.

edit:

Is there someone that hasnt that problem with windows 64bit VST plugins?

Thanks.


#2

Weird… It does look like a missing font, though I can’t think why this would happen…


#3

Thanks for the answer. I’m working on a really clean Windows 7 64 bit installation. Its wired because the 32 bit version works without any problem.
I guess its a 64 bit issue. I know its a bad example, but the text shoes up within my old VST 2.4 SDK (VSTGUI) plugins, compiled as 64 bit. Havent any idea and i’m not able to fix that issue with my knowledge at the moment.


#4

Its really wired, because it works if i compile the plugin in Debug Mode. Will check the build settings.
Edit: no success. Still no text in release mode.


#5

[quote=“patrickkunz”]Its really wired, because it works if i compile the plugin in Debug Mode. Will check the build settings.
Edit: no success. Still no text in release mode.[/quote]

It WAS a compiler option. Maybe some optimation properties that i had enabled or the preprocessor definition WIN32 that i hadnt defined. Copied the properties from the juce demo and it works perfect now.

Thanks again, sorry for taking your time, but maybe this thread will be useful for someone other. I hope so :slight_smile:


#6

Uhm… is it the one about the kind of floating point usage? the default is “precise”, that could otherwise be changed to “fast”.


#7

It was :slight_smile: