LassoComponent Look and Feel


#1

Please could we have a minor change to LassoComponent? Either sub-classable for a paint or draw method, or:

[code] LassoComponent (const Colour& fillColour_ = Colour (0x66dddddd),

                const Colour& outlineColour_  = Colour (0x99111111),

				int lineWidth_ = 1)

    : source (0),

      fillColour (fillColour_),

      outlineColour (outlineColour_),

	  lineWidth(lineWidth_)
    g.drawRect (0, 0, getWidth(), getHeight(), lineWidth);[/code]

and

[code] g.drawRect (0, 0, getWidth(), getHeight(), lineWidth);

[/code] Plus the obvious int member.

Bruce


#2

Sure, no probs. I’ll add a thickness variable.


#3