LicenseSpring causes plugin not to load in host but works in standalone

Hey there, so I’m trying to get the licensing part to work on my plugin and LicenseSpring seems like a good way to go.

They include a JUCE sample project which is a GUI app that works well and I’m also able to create my own GUI app and make it work, however, it doesn’t work in my audio plugin project when debugging in a host and I get one of those “The plugin couldn’t be loaded” type or errors.
Weirdly enough it does work in standalone mode.

Apparently, the part causing the problem is when it creates the licensespring config:

AppConfig appConfig( "JUCE Sample", "1.0" );
        auto pConfiguration = appConfig.createLicenseSpringConfig();
        auto licenseManager = LicenseSpring::LicenseManager::create( pConfiguration );

This basically calls this function:

LicenseSpring::Configuration::ptr_t AppConfig::createLicenseSpringConfig() const
{
    // Optionally you can provide full path where license file will be stored, hardwareID and other options
    LicenseSpring::ExtendedOptions options;
    options.collectNetworkInfo( true );
    options.enableSSLCheck( true );
    // options.enableLogging( true );
    // options.enableVMDetection( true );

    // In order to connect to the LS FloatingServer set its address as following
    // options.setAlternateServiceURL( "http://localhost:8080" );
    // If you use FloatingServer v1.1.9 or earlier provide Product name instead of Product code

    // Provide your LicenseSpring credentials here, please keep them safe
    return LicenseSpring::Configuration::Create(
        EncryptStr( "" ), // your LicenseSpring API key (UUID)
        EncryptStr( "" ), // your LicenseSpring Shared key
        EncryptStr( "" ), // product code that you specified in LicenseSpring for your application
        appName, appVersion, options );
}

Did anyone who uses LicenseSpring run into this issue? And how did you fix it?
Thanks in advance!

Just a wild guess because I haven’t worked with License Spring, but that could be intended behaviour. Most anti piracy solutions try to detect and prevent attaching debuggers. Maybe try a release build, see if it works with a plugin host.

Attaching Debuggers is not the problem, I worked with LicenseSpring for audio plugins but I never tried the demo project. Maybe try to create the Configuration without the EncryptStr macros and (very unsafe) plain text credentials while identifying the issue?
Also try commenting out each option, Im using different options I cant tell you for security reasons publicly.

Hey, thanks for taking the time!

I tried a release build and same issue. This even happens when the code has not yet been executed, simply adding it anywhere causes the plugin not to be loaded.

And yes, I already tried without the EncryptStr macros and it still doesn’t work. Really strange.

I emailed them but their support is quite slow, especially if you’re on the free plan just testing thins out.

Anyway, thanks a lot!