Linker error mousewheel latest TIP [solved]


#1

Does anyone know what this linker error means?? I am now operating from the latest tip. I do not have a mousewheel definition in my Editor.cpp or .h

[code]Ld “build/Release/EMpTy 250.component/Contents/MacOS/EMpTy 250” normal i386
cd “/plugin programming/own plugin/empty250 2/Builds/MacOSX”
/Developer/usr/bin/llvm-g+±4.2 -arch i386 -bundle “-L/plugin programming/own plugin/empty250 2/Builds/MacOSX/build/Release” “-F/plugin programming/own plugin/empty250 2/Builds/MacOSX/build/Release” -filelist “/plugin programming/own plugin/empty250 2/Builds/MacOSX/build/EMpTy 250.build/Release/EMpTy 250.build/Objects-normal/i386/EMpTy 250.LinkFileList” -bundle -framework AudioToolbox -framework AudioUnit -framework Carbon -framework Cocoa -framework CoreAudio -framework CoreAudioKit -framework CoreMIDI -framework DiscRecording -framework IOKit -framework QuartzCore -framework WebKit -o “/plugin programming/own plugin/empty250 2/Builds/MacOSX/build/Release/EMpTy 250.component/Contents/MacOS/EMpTy 250”

Undefined symbols:
“juce::Component::mouseWheelMove(juce::MouseEvent const&, float, float)”, referenced from:
vtable for EMT250Editorin EMT250Editor.o
ld: symbol(s) not found
collect2: ld returned 1 exit status[/code]


#2

The parameters to mouseWheel() have changed - you probably just need to do a full rebuild.


#3

I tried a clean all targets, have emptied cache, rebuild introjucer to the latest tip, I did total new rebuild with introjucer, making a new project, but still have this error. What do I do wrong?

Harrie


#4

Which static lib? If you’re using modules, there is no static lib (?)


#5

Which static lib? If you’re using modules, there is no static lib (?)[/quote]

Yes, I did not build one, I just wanted to be sure that I did not miss anything. I reverted back to the juce.2.0 and now my plugin works again.

But I still do not understand what I am doing wrong with the rebuild and the latest GIT update. I made a new project with introjucer (latest GIT-update), downloaded the latest GIT version, set the directories correct for this version, added the sourcefiles and compiled it. I still got the linkerror.

Harrie


#6

Your error tells you which file you need to look at! “EMT250Editor” apparently. Somewhere in there you’re probably including an old version of Component, with the older definition of mouseWheelMove.


#7

After deleting some older directories I could remove some wrong directories in the juceHeader.h. Solved.