Linking Problem for my 1st android test?


I want to compile an app for android. I have android studio 2022.2.1 set up with sd…

In projucer I create an androit export. The gradle built seems ok but when launching (in emulator or on my device) the application quit immediately. I thus tried with the Helloworld demo… SAme thing. Here is what I get :

Process: com.juce.helloworlddemo, PID: 3726
java.lang.UnsatisfiedLinkError: dalvik.system.PathClassLoader[DexPathList[[zip file “/data/app/com.juce.helloworlddemo-2/base.apk”],nativeLibraryDirectories=[/data/app/com.juce.helloworlddemo-2/lib/x86, /vendor/lib, /system/lib]]] couldn’t find “”
at java.lang.Runtime.loadLibrary(

Thus the problem is not finding… Not sure why…

I have tried to follow the android tutorial but it seems old and some choices (LLDB…) have changed or disappeard from the configuration of android studio…

Any hint ?

Thanks for your answer.

I finally was able to compile my project. I was probably a problem with android studio configuration. I uninstalled et reinstalled everything, updated graddle, reinstalled android sdk, and suddenly it worked…