Logic frozen when loading projects with multiple JUCE'd AUv3 instances


I found an issue that AUv3 plugin made with JUCE causes Logic Pro X frozen when save and load a project contains multiple plugin instances.

An AUv3 plugin made with JUCE is installed. A simple plugin that is just built based on the template can reproduce the issue.
Mac OS X Catalina 10.15.7, Logic Pro X 10.6.1

Repro Steps:

  1. Launch Logic Pro X and create multiple software instrument tracks, load AUv3 synth instance for each. In my case, I created 7 tracks.
  2. Create MIDI region that contains some notes for each track.
  3. Save a project and close the project.
  4. Load the saved project.


  • Load project successfully.


  • Logic Pro X freezes, cursor goes to infinite rainbow. Plugin seems not loaded completely (the plugin name is grayed out). 100% repro.

This does not happen for non-v3 AU. Checked JUCE 6.0.0, 6.0.5, and latest develop build and all repro.

Not sure if this is caused by JUCE or Logic. Does anyone sees the same issue?

Thanks for raising this. The issue should be resolved by this commit:

1 Like

Thank you for fixing this quickly! I’ve verified the fix with my plugin.

hi @ring2 and @reuk - i’m seeing this same issue but i have the above change (i’m using 6.0.8 from master). was there anything introduced recently that would have caused it to happen again?

for me i just need more than one instance in logic to trigger this. i’m on osx 11.2.3 and the most recent version of logic

ok totally confused but i removed all instances of the plugin from my system, then reinstalled, and now it’s working. sorry for the noise, i don’t know what was going on.

nope it’s back again.

i also tried to repro this with a debug build and couldn’t cause it to happen.

I don’t think we’ve made any changes in this area recently. Are you on an Intel or M1 mac?

I’ve tried to reproduce the issue in Logic 10.6.1 on both Catalina 10.15.7 and on the Big Sur 11.3 beta. I tested with JUCE develop, but there haven’t been any changes to the AUv3 wrapper since the last push to master.

To test, I created 16 tracks, each with an instance of the AudioPluginDemo AUv3 (built in Release mode), and added a midi region to each track. I then closed and re-opened the project several times. In all cases, Logic remained responsive.

Please can you provide instructions to reproduce the issue, and ideally some example code which demonstrates the problem.

1 Like

thanks - i’m trying to create a repro locally now, will post back when i manage to duplicate it (or when i inevitably find the bug in my code causing it :/).