Mac VST 64-bit build problems

The 64-bit build is choking at link with the following error:
[color=#0000FF]ld: warning: in /Developer-3.2.5/SDKs/MacOSX10.5.sdk/System/Library/Frameworks//QuickTime.framework/QuickTime, missing required architecture x86_64 in file
"OBJC_CLASS$_CIContext", referenced from:
objc-class-ref-to-CIContext in JuceGraphics.o
ld: symbol(s) not found[/color]

I must confess to being ignorant of much of what’s expected in the ObjectiveC world, so I’m not quite sure what to make of the error. Has anyone else seen this? As you can see from the path in the error message, I have both XCode 3.2.5 and XCode 4 on my machine. I have to stay with 3.2.5 for reasons related to Pace. With Juce 1.5.3 I was able to build the combined binary under Xcode 3.2.5, although I did have to tweak the Juce wrapper code a bit.

32-bit is working fine. To get as far as I got, I had to add this to AppConfig.h:
[color=#0000FF]#if LP64
#define JUCE_64BIT 1
#define JUCE_64BIT 0
The reason for that is that I build (or at least used to build with 1.53) combined binaries that contained both 32 and 64 bit code.

It’s choking because the Quicktime framework doesn’t support 64-bit architectures. I’m afraid you’ll either need to only build your app as 32-bit, or disable Quicktime.

Are you using Quicktime now when you weren’t before? BTW, my AudioUnits 32/64-bit build went off without a hitch.

Maybe you’re getting quicktime because you’ve enabled the juce_video module?

It felt so right when you said that. I just checked, but alas I’m using the same Juce modules for VST that I’m using for AU. AU builds fine and VST doesn’t. It feels like something either in the VST wrapper or in the VST SDK. I don’t think it’s likely to be in the SDK, since it’s exactly the same one that worked successfully in Juce 1.53.

Well I guess that in the past you weren’t doing a 64-bit build?

Au contraire, I built and shipped quite a few Mac VST plugins with 32/64 bit executables. I did have to do some minor tweaking of the 1.53 VST wrapper to get it done but it really was minor. Let me know if you’re interested and I’ll send you the wrapper (it’s actually 2) offline.

Well I really don’t know then! Something must be adding the quicktime framework, but I really don’t know what…