Made my first JUCE program as well as my first C++ program


#1

This is released under the GPLv3 license, so I have removed the splash logo and data collection. Could someone take a look through it and let me know if there is anything I need to fix as far as licenses go? This is my first time using a licensed framework and I don’t want to screw up with licenses. Thanks.


#2

Hi @MosesofEgypt,

It’s good that you have made the source code of your app available via bitbucket.

More importantly, however, everywhere where you publish your app’s binaries, you must include prominently displayed links to the source code and instructions on how to compile it yourself. So to be able to check if you comply to the GPLv3 you should send us a link where your typical user would go to, to download your app. If it’s only via bitbucket than I think you are ok.

Also, it’s important that it’s easy for a developer with reasonable knowledge to be able to build your app. I tried cloning your repo on a windows 10 machine with the latest VS 2017 but it wouldn’t build. Some errors about missing includes.


#3

What are the missing includes? My project requires the windows 8.1 API, which is not included on windows 10 from what I understand. Other than that, I don’t know what includes I could be using that aren’t either provided by JUCE, or are standard C++ includes.

Also yeah, I simply link people to my Bitbucket repo’s download page for the download since it’s easy to maintain and is always up to date.

This is the only place I’ve posted it so far.
http://forum.halomaps.org/index.cfm?page=topic&topicID=50342


#4

It wasn’t a system include. It was looking for an include somewhere in your project.


#5

Not sure about the building part. It seems like it’s a gray area in that regards, lots of Linux based boxes publish their code under the GPL, but sometimes not the way to build them (for a new firmware for instance).


#6

Well hopefully I can get it figured out. I’m going from almost zero Linux experience to trying to set up a codeblocks, make, and android studio development environment, and on Friday I’m gonna get some help from a friend of mine in doing so. When I run into the missing includes I’ll be sure to fix it. Also, are you trying to build using the visual studio solution in the folder, or are you using the jucer file to create a new exporter?


#7

Well, took a couple hours the last few days and got this working on lubuntu. Turns out I accidentally set up too broad of a rule in my .hgignore , and it ignored a folder of source files… The includes are all there now, and Composer loads and runs on Linux now. Next I guess I’m going to start getting it to compile in Android Studio. Anything I should know in advance? I dont have a playstore developer account yet, so keep that in mind.