Mavericks adventures


#1

Hi guys just updated two of my macs to Mavericks, i can share a little of my experience:

Xcode 4.6.3

  • You will be prompted to enter your admin password at launch, yadda yadda something.
  • If your project uses as build setting the Defaults SDK, it will fail to build instantly since the default sdk is now 10.9
  • You have to install the command line tools if you dont have xcode 5, use: xcode-select --install
  • If your project uses the build fat binary option (Standard ARCH 32_64 bits something), it will get stuck on the Building Universal Binary Part, no errors just stuck forever, and i mean forever, i even did sudo opensnoop - Xcode to see what it was doing, nada, just stuck.

So i updated to Xcode 5 (actually 5.0.1) and:

  • Project builds correctly no fails, yay
  • Another project that uses a static library (somelib.a) fails to find some headers provided by that library, that seems like a bummer, will get to it later, now i must wait for spotlight do its thing.

Overall Mavericks is nice, no big features, apple stashed 2 icons on my dock maps and ibooks, i will open them someday,  i dont like having multiple top bars across my monitors, they used to look much cleaner without them, anyway free is always nice, and Xcode 5 looks a little nicer (ui)

 

 

 


#2

 

Thanks for the reconnaissance mission.  Upgrading soon, but always like to know what I am getting into. 


#3

 

i will have to face the peril too, soon.

 

 


#4

Make sure to update to latest Xcode 5.0.1. With Xcode 5.0 debugging does not work.


#5

>  i dont like having multiple top bars across my monitors, they used to look much cleaner without them

 

You can revert to the old multi-monitor behaviour in the settings.


#6

I'm getting what looks like a deadlock using CoreAudio when moving to Mavericks. When my app starts up it goes through the normal stuff of initialising the GUI and initialising audio via the AudioManager class. However the app often locks up after a few seconds. I've tried running this using the same binary compiled with Xcode 5 on a OSX 10.8 machine, and the problem doesn't occur. The problem is also not visible in Windows. I'll post the details as a new topic so that it shows up as new


#7

Step into registerBasicFormats() and see where it hangs

 

Rail


#8

Turned out to be a real deadlock with Juce and CoreAudio getting in each other's way. And, as luck would have it,  Jules had already found and fixed it.