Maximilian maxiEnv not working


#1

I really need help. I’m trying to build a synthesizer using maximilian library. maxiOsc works just fine, it outputs a sine based on midi messages. But when I try to use maxiEnv and more specific, adsr function from maxiEnv class and then build it as VST and import it into fruity loops, it doesn’t output any sound at all. Please, help me. :smiley:


#2

I tried using maxiEnv::adsr in a synth at some point and it worked…
You didn’t share much details about your setup so it’s hard to say why it doesn’t work in your case.

This tutorial from @JoshuaHodge explains step by step how to set things up for maxiEnv in case you aren’t sure (also see the other episodes if needed, they explain other aspects of building a synth).

One more thing: there’s a bug in maxiEnv::adsr: when sustain is set to 0 it starts behaving strangely, sometimes missing notes. Looks like there’s a very easy fix already, but nobody have merged it yet (I suspect the original Maximilian repo is not being maintained anymore): see https://github.com/micknoise/Maximilian/pull/64/files#diff-768ac85d0290a79619e782a3cc5cd8c7R1582 for the fix.

I hope this helps.