BinaryData.cpp files generated by the Projucer are sometimes submitted into source-control (an example of this can be found in the bootstrapping of the Projucer itself).
When merging branches containing these files, there are spurious conflicts in generated variable names such as
While solving the conflict is not hard to do (just re-generate the files), all these small easy stuff get in the way.
It would be nice if instead of using
temp_binary_data_57 Projucer would use
temp_UnityPluginGUIScript_cs - or any form of name which does not depend on how many entries were before. Then there wouldn’t be so many spurious merge conflicts in these files.