Minor naming convention inconsistencies for device logging macros


#1
JUCE_COREAUDIO_LOGGING_ENABLED=1
JUCE_WASAPI_LOGGING=1
JACK_LOGGING_ENABLED=1

Tbh, I’m a bit surprised there’s not one global flag for logging audio device issues, one that’s part of the module which can be toggled on/off via the Projucer.


#2

Yep, these were added in a rather ad-hoc fashion over the years, would be worth having a bit of a tidy-up at some point.