Missing "winInet.h" with VS 2017 and JUCE v5.2.0

windows

#1

I have looked around this forum and on Microsoft’s forums as well to repair the issue.

The issue is that Visual Studio keeps throwing errors on not having “winInet.h”.

I have done a clean install 4 times, and nothing has worked so far. I have also tried to repair the Windows 10 SDK, and set the Target Platform to the version I have installed.

I also tried to find wininet.h on my hard drive, but it is not in any of the Visual Studio Kit include files.

At this point it seems like a Microsoft issue, but I just wanted to resolve this error because I am getting extremely frustrated.


#2

Which target SDK have you got setup in Projucer? 10.0.16299.0 is the recommended one as seen in this screenshot

Have you got 10.0.16299.0 installed? When you right click on #include wininet.h line in juce_BasicNativeHeaders.h what is the search path VS2017 reports? Is it looking in 10.0.16299.0 subdirectory?

Lastly, are you trying to build Projucer or a demo app or your own app? If you are building Projucer and you get missing wininet.h error, then try opening Projucer_App.vcxproj and replacing all 10.0.15063.0 with 10.0.16299.0 (after you get 10.0.16299.0 SDK).


#3

I have to admit that I’ve had this problem as well, but it went away after a re-install of the Windows SDK via the VS installer. Maybe there was a broken update of VS which by mistake didn’t include this header?!? Anybody have any ideas?


#4

I did everything that you said to do, so I assumed that it was a Visual Studio issue, as I deleted/reinstalled too many times.

Still not sure of the error unfortunately, but I did a clean install and it did the trick!


#5

I’m glad to hear that you solved the issue! It’s a little strange, a number of people have reported the same problem. So clean install seems to help!