Monospaced fonts are not monospaced


#1

The typeface name returned for getDefaultMonospacedFontName() and the resulting Font() object are not monospaced, and break how the CodeEditor component wokrs, i double checked it in Introjucer by clicking a .cpp file, and it’s the same (screenshot attached)
[attachment=0]introjucer_monospaced_bug.jpg[/attachment]


#2

Thanks, will take a look. This is obviously a platform-specific problem, so are you using windows 8?


#3

Umm… No, can’t reproduce that on my win8 machine. What fonts does it list?


#4

Yes i’m on windows 8 - x64, that worked a git-revision ago, it was broken when i did an update today. Here is the list of fonts that is shown (it’s kinda short?). I also deleted all the settings that Introjucer writes and re-built it, it still shows a non-monospaced font when i open a project:

[attachment=0]introjucer_font_list.jpg[/attachment]


#5

Ah… Sorry, I was running an older build on my win8 machine. Thanks, will get that fixed asap.


#6

Fixed now.


#7

Thank you it’s working now.