New experimental QtCreator exporter for IntroJucer


#21

I think that support for QtCreator would nice since it’s lightweight IDE and can use also Windows…

How about CMake, does JUCE has support for it ?


#22

I’d like to try this and I’ve downloaded the package. @ https://github.com/seebk/JUCE

Projucer is “installed” and Qt is installed. What next? I’m on Win10.

EDITED: I dug a little deeper and SOLVED Thank you! “Hello JUCE” finally!!


#23

Not so much a reply to myself but a hat-tip to the JUCE crew and Seb. I’m at this very moment banging on a MIDI keyboard through the JUCE plugin host via Qt 5.7 on Win 10 :slight_smile:


#24

I think that everyone who work the Juce sdk and Linux development should use this forked repository. Until possible CMake support arriver to the JUCE sdk.


#25

Well I won’t be doing that again! Until now I’ve only used a USB midi keyboard with the JUCE demo, today I decided to try my Guitar-> AudioInterface and the Juce “Noise” tutorial. I built it, ran it and it worked. What a horrible sound! That’s enough of that. I killed the App and closed the Qt IDE. What’s this? I’m still hearing the distorted sound. Hmm I better do a restart, the App hasn’t let go of the SoundCard. After a restart and it’s still distorted, so I put on an Audio file to try and grab it back, it worked OK for a moment then - boom Windows 10 BSOD.


#26

Mmhhh, yes working with audio grabbing is always resource hungry and debugging may not best solutions always perhaps … Have you try working with Linux at once ? I’m not working with audio, QtCreator and pro file support is excellent solution to enable A grade IDE in Linux.


#27

Yes I have latest Mint and SlackoPuppy on a Laptop but my Audio Interface will not work on Linux. But you’re right I need to spend more time away from DAW PC.


#28

For the record, I built Martin Zuther’s Compressor in Qt yesterday. Dropped the dll into my x86 Plugs Folder and fired up REAPER. When I finished, I closed REAPER and put a video on for my daughter. Couldn’t listen it - sound compressed and distorted to hell. Aha, the plugin hasn’t let go the Soundcard again! This time I rebooted and disconnected the external soundcard and went with the internal…Later I went back into REAPER, messed about with the Compressor again and closed when finished. No Compression this time, It has let go…

So it’s quite possible that my aging Focusrite was the problem. Better write my letter to Santa tonight!!


#29

hi @sebk,

that is a great project. I tried QtExporter a little bit and it seems to be a much better tool than Xcode. Is there any plans for MacOS support for the exporter?

Johannes


#30

I never tested it on OSX but it should be easy to port. Have a look at
the generated .pro file, it probably just requires a few OSX specific
compiler and linker flags. As I am not a Mac user I will quite likely
never work on this, but if anyone wants to create a port I would be
happy to merge your changes in above repository to share it.

Sebastian


#31

For the record this is a brilliant project, thank you for the repository! QtCreator is about the only usable IDE I’ve found working for linux having come from the comfort of OS X.

I haven’t looked very hard yet, but I’m struggling to get the debugger working with these projects, is there anything in particular I have to do?


#32

Could you be more specific? Make sure paths are correct.


#33

Thanks for getting in touch so quickly Ian and apologies for the vagueness, I’ve just been switching distributions today and have been setting up JUCE and qt creator so will get back pronto what the exact problem is!


#34

I am trying hard to get OpenGL running smoothly on Raspberry but I am not really getting there. On OSX and Windows, list boxes and other such things scroll absolutely fine (thanks for the nice and easy OpenGL integration in juce) but not on Jessie. Further,I do have a similar application running using OpenGL on the same Raspberry and this scrolls really smooth. So, it must be possible.
The similar app was build with QT, probably supporting Wayland. Would I benefit from the OpenGL integration in QT?

Thanks
Joerg


#35

Somewhat disappointed that there is still no Qt exporter in JUCE, but there is for Codebolocks! Seriously? sebk, could you update the source package please! Oh did I mention, I had to re-join. Pain.


#36

Sorry, I quit working on the QtCreator exporter since JUCE 5.0. There where too many changes in the exporter code between JUCE 4.3.1 and JUCE 5 that I could not easily merge the latest JUCE with my changes. Currently, I do not have free time to refactor the QtCreator exporter and probably will not in the next months.


#37

That’s a shame. Thanks for your reply.