New install, "Open in XCode" grayed out


#1

I’m bringing up a new dev machine. OSX 10.8.2, Xcode 4.5.2, command line tools installed. Downloaded the prebuilt Introjucer and let it update modules. I also performed the incantations from adfernandes’ post in the “AU under XCode 4.4” thread.

Creating a new audio plugin project, I have “Build AudioUnit” and “Plugin wants midi input” options enabled, appropriate stuff in the name and descriptions fields.

The “[Save Project and] Open in Xcode…” buttons are both disabled. Any ideas?


#2

Does an XCode export exist?

Chris


#3

I don’t know what you mean by an XCode export.


#4

Exporter = target

Choose Config and you can see what targets exist for the project. In the example below, there’s only a VS2010 target. To add another one, right click on the project name…

[attachment=0]Introjucer.png[/attachment]


#5

My Introjucer (3.0.0) looks nothing like that. In particular, there’s no tab bar between the menu bar and the panes, and poking around the menus yields nothing like a Config option. I’ve had this working on another machine without needing to explicitly create new targets.

ETA: Ah, okay, found it – had to scroll down below the Modules section in the settings pane to find “Export Targets”. Thanks.


#6

Ah, you’ve got the old version then. I’m working with a build from what was the latest tip on GitHub last week.