NI Massive X - Black UI with DPI Awareness Disabled

Massive X has recently been released and I’m already getting complaints from Windows users that the UI is appearing too small because it doesn’t support DPI Awareness (at least in any form JUCE does).

What I usually do in these circumstances is tell users to disable DPI awareness which forces Windows to bitmap-stretch the UI. However, with Massive X all I get is a blank window.

Any ideas on this one?

Kontakt has similar issues where it doesn’t render correctly in a DPI-unaware window - I spent a while trying to figure out what the issue is but no luck. In the AudioPluginHost it’s just a special case where we always open it in DPI-aware mode and live with the fact that it’ll render smaller. Guess I’ll need to add Massive to that check now too…

I’m not sure what NI are doing for their high-DPI scaling on Windows but it doesn’t play well with what we do in our hosting code unfortunately.

Hmm. That was what I was afraid of.

The user who reported this has come back and said it works in Reaper so maybe there’s something NI are reporting we can take advantage of? Does anyone have a contact at NI’s plugin team?

I know this is old but the situation has been reported to me again recently and this hasn’t been resolved.
Annoyingly, this does now work correctly with Kontakt so maybe there’s something different about Massive X.

They’ve also released the VST3 version of the plugin now and that also displays black when stretched.
Anyone got any ideas about how to fix this?

I just tried this out in with the latest Massive X demo 1.3.5 (R238) VST3, JUCE develop, and Windows 11, and I see very similar results in the AudioPluginHost and REAPER.

With auto-scale on, the plugin looks pretty good in both hosts (I’ve chosen 50% scaling from the in-plugin zoom control because my screen is quite small):

Now, when I close both plugin windows, enable auto-scaling in both apps, and then reopen the plugin windows, I see this:

My laptop screen is using 125% scaling, so I suspect that has something to do with the black border around the screen. When I switch to 200% scaling, the border gets larger:

I also noticed while debugging that the editor doesn’t implement the IPlugViewContentScaleSupport interface, and instead seems to be querying the OS directly. My guess is that the plugin isn’t taking Windows’ automatic scaling into account when rendering in this mode. Maybe this is worth reporting as a bug to NI.

Finally, I tried resizing the window with auto-scaling both enabled and disabled. In both modes, the editor remained visible, in both the APH and REAPER.

Are you testing with the same version of Massive X as me? If so, perhaps this issue is OS-dependent (it looks like you’re testing on Windows 10).

I’ve installed the latest version of Massive X from Native Access, v.1.3.5.
It does sound like a bug in Massive X, it’s annoying it seems fixed in some of their other plugins though. I’ll try and report it to them. Cheers for taking a look.