No audio from VSTi unless transport started


#1

Using the StepSequencerDemo, I’ve added a button to load a vst instrument. However the instrument doesn’t produce sound until I engaged the transport:

Couldn’t get the code to format correctly when pasted. Hence the github link :disappointed_relieved:


#2

Can you check the value of Edit::playInStopEnabled? This should be enabled by default and is required to run the audio engine when the transport is stopped but may have been turned off accidently?

As a side note I would show the plugin window on the newPluginAddedCallback, it’s probably better to add a button for this or you won’t be able to get it back if you close it.


#3

Setting playInStopEnabled resolves the issue. I didn’t explicitly disable it anywhere, however.

Yes- I was just doing some quick testing.

Thanks!