Normalisable Range file problems

Hi there, a bit new here but i’ve in the last few days had an issue with the Juce_normaliseablerange.h file stopping any builds of any projects, i didn’t edit it (knowingly atleast) but now even in projects that were building and running fine it gives me the same error, line 242
jassert (end > start);
, gets an ‘expected expression’ error.

any ideas? i tried reinstalling juce but the same problem persisted

you have a bug in your code, where end is less than or equal to start. it looks like the function NormalisableRange::checkInvariants () is called to check settings when they change. so when you hit the assert in the debugger, follow the stack trace up to see where the wrong numbers are coming from. This is called debugging :crazy_face:

If I understood the original poster correctly, it’s a compile time error. But does really sound more like it’s hitting the Juce jassert at runtime instead?

hmm… now that I have reread it, I think expected expression is a compile error… I would make sure the juce namespace is turned on, maybe some strange code collision?

can you build the demo apps?

Did you update your local Juce repo/copy recently? If you’re using Projucer, you might want to delete the Builds and JuceLibraryCode folders before exporting from Projucer. That helps clean up leftover crud from earlier versions of modules/submodules you’re using.