Not able to accept privacy policy and EULA from within Projucer on Linux

jucelicensing
projucer

#1

I have Ubuntu 17.04 and downloaded the source of version 5 from GitHub and compiled the Projucer. After login, when I want to accept the privacy policy and EULA, it is not-clickable. Am I missing something?
Also, where are the configuration files located, where the Projucer stores the login credentials and other things?


#2

This bug should be fixed on the develop branch now.


#3

Could you provide me a link to the bug report? It seems either the bug is not yet fixed or I still don’t know how git works. Did I do anything wrong?
These are the (main) steps I have done:
git clone https://github.com/WeAreROLI/JUCE.git git checkout develop


#4

This is the commit. The git commands you are using look good to me. Did you then re-compile the Projucer? You can also just re-download the binary from the juce website.


#5

I recompiled it now from the develop branch, and tested the binary from the website. Nothing worked.
According to the description, the commit fixes a blank window but I cannot click on the “accept privacy policy and EULA”. The login works fine.


#6

Now I have tried it on another computer and it works. After disabling the Paper GTK-Theme it also worked on my computer. Now that I know what causes the issue I will report it there.

Maybe you could give me or point to some information what was used in addition to libwebkit2gtk-4.0-dev in the Projucer in order to include it in the bug report.


#7

Hi @temrix, I’m glad it works for you now. It’s odd that the Paper GTK-Theme could have such an impact on UI behaviour. For a list of further dependencies, please see this post.