OpenGL Render fails


#1

Hi,I get the latest source from sourceforge.net and compile it suceessfully, I run the jucedemo, when switch “use opengl renderer” , the application will crash because of glGenFramebuffer is not supported, my opengl version is 5.1 and use NVIDIA Geforce 9400 GT Graphics card, I don’t know what’s the problem.


#2

That’s very odd - if the GL version really is 5.1, then the driver must provide that function!


#3

OpenGL current version is 4.2. I doubt your OpenGL version is 5.1
Can you double check this, and also post a stack trace here ?


#4

The version 5.1 of opengl is c:\windows\system32\opengl32.dll,I use glew tool to list my graphic driver support GL extention info, the FBO extention is missing.
the version of opengl is not supported by my graphic card which only supports OpenGL 2.1, after I update my graphic driver, this problem is solved.

but is there one simple way to solve this for those computers which support GL lower version ?


#5

Yes, I need to do a bit more tidying up of the GL stuff, to make it cope with systems that don’t support newer extensions.