Out of the box, demos won't load in Plugin Host


#1

I just downloaded JUCE for the first time and tried to follow the simple tutorials and neither my starter plugin or the included Audio Demo Plugin will load in the plugin host. They won't load in Mainstage either.

"Note that the following files appear to be plugin files, but failed to load correctly."

I know I'm a JUCE newbie, but this should work, right?

 

 


#2

Check that you’re building a 32 bit or 64 bit version whichever matches the Host

Rail


#3

I was building a 32/64 universal plugin, so I changed it to the default setting and got the same result. 

When running the PlugIn Host from Xcode, I noticed this error:

2015-11-06 17:35:59.287 Plugin Host[29779:2280043] Error loading /Volumes/Home/ray/Library/Audio/Plug-Ins/Components/JuceDemoPlugin.component/Contents/MacOS/JuceDemoPlugin:  dlopen(/Volumes/Home/ray/Library/Audio/Plug-Ins/Components/JuceDemoPlugin.component/Contents/MacOS/JuceDemoPlugin, 262): Library not loaded: /System/Library/Frameworks/CoreImage.framework/Versions/A/CoreImage

  Referenced from: /Volumes/Home/ray/Library/Audio/Plug-Ins/Components/JuceDemoPlugin.component/Contents/MacOS/JuceDemoPlugin

  Reason: image not found

 

I tried adding CoreImage to be linked in both the plugin and the plugin host, and still get that error.


#4

I ran into the same issue.

Fixed it by changing the Deployment Target from 10.11 to 10.10, cleaning my project and rebuilding.

 


#5

Thanks for the tip, but for me, it was the Base SDK.

I had both the Base SDK and the Deployment Target set to Default. I changed the Base SDK to the latest version (10.11) and then I could set the Deployment Target to almost anything...in my case, I set it to anything between 10.7 and 10.10 and it was fine.

Thanks.