parseWildcards (juce_DirectoryIterator.cpp)

parseWildcards is a flat static function in juce_DirectoryIterator.cpp. In my opinion it should be either a public or a private static member of class DirectoryIterator, because with the unity build the static qualifier loses its meaning as the translation unit is not limited to just the .cpp in which it appears.

This applies to all global functions with the static specifier.

Yes, good request, I can change that…

Do note that this happens in various places throughout the entire source tree, not just the directory iterator.

For example juce_Uuid.cpp contains an anonymous namespace (at the top) which of course loses much of its meaning since the translation unit is no longer limited to the file in which it appears.

True, but I’d expect most of these things to be quite obscurely named, and highly unlikely to cause any clashes (?)