Plugin host, number of Ins/Outs


#1

The internal filters for the plugin host are showing up with more inputs and outputs than can fit on the screen. I’m looking at how I can change the number of channels on the internal filters, but so far it eludes me.


#2

You must have a really tiny monitor, or a really awesome interface :smiley:


#3

I wish!


#4

Anyone have an idea of how to fix this problem, i.e, the internal filters show up with 256 inputs/outputs? It makes it impossible to use the Audio Plugin Host to debug plugins. I’ve looked through the code but for the life of me can’t see where the number of connections for internal filters are set?


#5

Hack it by putting the whole graph view in a viewport?


#6

Surely there’s a more straight forward way than that?!


#7

Make all the filters appear as cubes with OpenGL, and place connectable I/O nodes on them, (and so on)…?

Tbh, a Viewport is actually the simplest way. You can probably hack up a zooming aspect to it too. There really aren’t any other options.


#8

Now you’re talking! :smiley: But seriously, I’d rather not implement a viewport for this, and then have to re-implement it every time I update my JUCE source. I’m interested in WHY the internal filters have 256 inputs and outputs on Linux, when there are only 2 on other platforms? Is there some kind of Linux specific setting that determines the default number of inputs and outputs? If I knew that I could go about changing it back to something more manageable.


#9

Hm… fair enough. Not sure why the you would get a ridiculous number of inputs and outputs for the actual Input and Output filters… You’d have to step through the wrapper to find out.


#10

I didn’t test this, but:
go to MainHostWindow.cpp, function MainHostWindow::MainHostWindow()

Change this

to this


#11

Are you using some kind of virtual device like Jack which, as masshacker points out, will open as many channels as you ask for? What does the JUCE device selector report for the number of available ins and outs?


#12

Looks like I killed more brain cells that I thought over the holiday period. Making those changes to the device manager initialise method solved everything!


#13

No dice on the 256 to 2 ports change. Something else is in charge of this, and it’s not the other references to the number 256 in that file either.


#14

Just to be explicit, I am experiencing the same problem as Rory. I am running linux mint. Since this is my first time working with Juce, I thought the audio plugin host was unusable.

Masshacker, I notice this inconsistency… when I change those 256 magic numbers to 2 and run it, thee is no change. HOWEVER, if I am listening to some music then I launch the plugin host while audio is playing, I get 2 inputs and 2 outputs (or whatever number I have set there.)

Is this weirdness reproducible for you Rory?

Why are these parameters being ignored when there is no other processes accessing audio on my system?


#15

Sorry for not getting back to you sooner on this, but masshacker’s fix works fine for me? I’m using 64-bit kubuntu?