Plugin "synths" won't load in Sonar


#1

Hi, Sonar doesn’t seem to like loading plugins that have “plugin is a synth” checked. Reproducable by setting this flag on the demo plugin.


#2

That just sets a flag in the plugin’s description - it sounds more like a Sonar quirk or misunderstanding rather than a bug on our side.


#3

hi Jules. ok, so does that mean I have to have 2 builds? I’ve already gone from not having the flag on to make some DAWs happy, but it seems either way round, something isn’t going to work with that flag set/unset…


#4

I’ve never heard of any problems with that flag before… Are you sure it’s not just Sonar being weird, e.g. maybe if it has already seen a plugin listed as an effect and then it sees the same one as an instrument, perhaps it gets confused?


#5

i’ll check that out - i’ll clear down all the plugin DBs and rebuild them… cheers


#6

ok, just performed these steps (develop branch FYI)

  1. Set Sonar to manual scan - removed the juce demo plugin.dll
  2. Did a manual scan - confirmed demo not appearing in Sonar list
  3. built demo plugin out of the box.
  4. Did a scan in Sonar - plugin appears as an effect and can be loaded - behaves as expected
  5. Removed dll and rescanned - confirmed no longer appeared in Sonar
  6. Set the “is a synth” flag in Projucer, rebuilt dll
  7. Scanned in Sonar - plugin appears as an instrument
  8. Tried to create an instrument track with demo plugin as selected instrument and got the above error message

#7

Sounds like their bug then.


#8

ok. have contacted them, will update with any responses.


#9

Well, don’t expect them to be particularly interested - it’s a bug that only plugin developers would be able to trigger!


#10

Is your plug-in actually a synth or an audio plug-in?

If it is an audio plug-in and you are playing with the “synth” flag in order to make it receive MIDI in SONAR, then you should not enable it as a synth in JUCE.

Instead, you should configure it in JUCE as a regular audio plug-in, and only afterwards open the plug-in manager in SONAR and manually set the “Is a synth” flag for it.

(this is only for VST2 audio plug-ins though. Luckily this is not necessary any more with VST3 if I recall correctly)


#11

its a MIDI plugin. tbh, I’m not really fussed what it’s marked as, but, given feedback from users (FL Studio, Cubase IIRC), it’s better for these types of plugins to be marked as synths so they appear in the correct section of the DAW. All I’m trying to avoid really is having to build different DLLs for different DAWs.

it’s the same as the “midi effect plugin” flag which I used to have it marked as - this stopped the AU loading in logic


#12

Interesting - how do I do this? Maybe I could unset this flag instead?


#13

Enabling it will move the plug-in to the VST Instruments category, and disabling it will bring it back into VST Audio Effects


#14

thx - doh, i was looking in options for that rather than the manager… will give it a go.


#15

that works.

in an interesting turn of events, loading it as an effect, then switching it back to be an instrument allows it to load as an instrument. once that has been done it appears to work ok going forward - def seems to be some kind of Cakewalk issue…

will get the customer to try this and see if it solves for him too… thx for the idea!