Powerpc build broken


#1

The magnification support stuff seems to be only available since OS X 10.6. #ifs are needed for powerpc builds to still work…
See patch at https://github.com/yairchu/JUCE/commit/37c43d4f3bf3fa322f3ac844772cb961dbd2e248
Cheers! Yair


#2

Thanks! But shouldn’t it be MAC_OS_X_VERSION_MAX_ALLOWED rather than MAC_OS_X_VERSION_MIN_REQUIRED?


#3

To be honest I’m not completely sure what MAC_OS_X_VERSION_MAX_ALLOWED means exactly. If I understand it literally to limit the OS X version I want to allow my program to run in, I pretty much want to allow everything… So using that it would include this new code and fail compilation when targeting ppc… ??


#4

Well, if you’re using 10.8 SDK but with compatibility set to 10.5, then MAX_ALLOWED would be 10.8, and MIN_REQUIRED would be 10.5. In that case you’d want this code to compile so it’ll work on later systems. I think it’s only if you’re building with the 10.5 SDK that you’d want to disable it.