Problem using 352.8kHz sample rate on macOS audio application


#1

Hi,
I’m developing an audio application running on macOS and I am encountering some problems using a sample rate equals to 352.8kHz. The application performs a 2x, 4x, and 8x upsampling. Using a ‘base’ sample rate of 48kHz everything works fine (2x, 4x, 8x). When I select a ‘base’ sample rate of 44.1kHz, 2x and 4x upsampling works fine but 8x (352.8kHz) does not sound correctly.
I’ve also tried using the application of the AudioDeviceManager class tutorial and I’ve noticed that if I select the DAC as the output device, the 352.8kHz value is missing from the sample rate combo box.

As output device I’m using the M2Tech HiFace DAC.

Has someone experienced the same issue? Any Hint?

Regards,
Loris


#2

Hi, may I call you Batman? :wink:
Do you really have a soundcard being capable of producing audio with 384kHz? If yes, why on earth would you like to listen to that? Every little non-linearity will produce so many artifacts into the audible frequency spectrum, your audio won’t be better. Especially when it arises from a 48kHz signal.

Edit: I just googled your soundcard and it really can play 384kHz, three full octaves of frequencies, not being audible by the human ear.

It might sound bad, as your sound-card simply cannot reproduce a 352.8kHz signal.


#3

There might be a use case, I once worked for a German company (Cube-Tec Quadriga) enabling quality controlled 4x high speed audio ingest. So you needed 192kHz sampling rate. It was quite demanding on your analog gear.

I see in the sources, that theoretically JUCE is capable of selecting 384kHz, I don’t know what’s going wrong, could be on the driver side or somewhere else in JUCE…


#4

Hi daniel,
you are right 384kHz is there but 352.8kHz is missing. Adding it solves the problem.

Thanks a lot.


#5

#6

I wanted to play around with that sort of frequency rate to create an I2C capture and debugger and there’s plenty of other use cases in electronic diagnostics and signal processing.