Push notifications for iOS in Projucer doesn't turn on the capability in XCode

Hi, this isn’t get transferred into the capabilities on XCode and I have to set this manually every time I save the Projucer project.

thx

What isn’t being added in Xcode? If I enable push notifications for an iOS or macOS exporter in the Projucer then the “Push Notifications” capability gets added to the project correctly:

Hi, not happening for me and hasn’t been for some months. I have to go and manually add it every time I save the project in Projucer.

Just saved now:

Are you on the latest JUCE version? Have you tried enabling push notifications for a freshly created project and seeing if that works?

@leehu what is the name of the Xcode capability that you have to set manually? In your screenshot, “Remote notifications” is checked (like in Ed’s). So I’m a bit confused about what is not working.

My screenshot isn’t showing “Push Notifications” even though it’s set in Projucer. Push Notifications is present in Ed’s

1 Like

Latest built from develop yesterday. Yes, just created a brand new project and it’s not being added.

Are you sure you’re enabling the setting on the correct exporter? Can you grep the .pbxproj file for com.apple.Push - it should be set to 1.

strange, the value is 1, but Xcode is ignoring it.

maybe an Xcode bug?

image

When I add the Push notifications manually, the following lines are added to the Standalone_Plugin.entitlements file:

<key>aps-environment</key>
<string>development</string>

not sure if that has any bearing?

I don’t think this has ever worked for plug-ins - this line has been there since the push notifications code was added a couple of years ago so the entitlement will never be added for plug-in projects.

But is that was determines whether the Push flag has any effect or not?

Yes it seems that you need both the attribute and entitlement for them to be enabled. I can’t see a reason why we don’t currently add the notifications entitlement to plug-in projects so I’ll get that changed.

1 Like

thanks!

You’ll need to re-build the Projucer and re-save your project.

1 Like

thanks - all working fine now.