[Re-opened] AudioPluginHost lose AU plugin after debugging under standalone

I run into an issue which might be a bug in the JUCE AudioPluginHost, I couldn’t save my plugin in AudioPluginHost, not the parameters, the whole plugin won’t get save to the host project file, after I add this plugin as a new filter then save the project, it won’t appear when I re-open the project.

I’m using macOS Monterey 12.6.2 and the latest development JUCE 220d6fc5eeef1b602b24a99aebf93aed85966072


  1. Create a new plugin, debug it in AU format, save the project
  2. Debug it in standalone format
  3. Reopen the project

The project will lose this plugin after re-open.


I just solved the problem, when you rename your plugin, Projucer will generate you another xcode project file with the new name in Builds/targetplatform folder, so there will be a lot of generated files which are duplicated. After I deleted those files with dated name, this plugin finally showed up in the saved host project automatically.

Hope this will help future developers who hesitate on their plugin name.

Note that in the future, you can simply trash the entire Builds/targetplatform folder, and Projucer will rebuild those contents. Probably that would be a good idea after making a major change like renaming the project.

1 Like

Another update for this issue…

I found the issue doesn’t come from name changing, it came from compiling standalone plugin.

If I debug my plugin in standalone mode, then the input won’t work at all, at the same time, the host project which has this AU plugin saved will lose this plugin when re-opened.

But if I delete the whole Builds/targetplatform folder and re-compile the AU version, it will re-appear in the host project. If I debug it in standalone again, the AU will get lost again…

@fr810 @attila