Registry Tools in Platform utilities


#1

I noticed that in the documentation for the PlatformUtilities Class the windows registry methods are stated to be for WIN32 only. I’ve done some testing and it does seem like those methods are not work correctly on an x64 platform. I was wondering if anyone had any suggestions i need to be able to create and delete registry keys and values on both x86 and x64 systems in my application.


#2

In what way are they failing? I had a few problems with them under Vista too, but realised that it’s just that the permissions are quite strict, and unless you run with admin privileges, the app’s just not allowed to access a lot of the registry.


#3

What I’m trying to do is pretty simple. I’m just want to give the users an option to run the systray app at startup. So i need to be able to create and delete key and value with the apps working path in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run.

So far none of the platformutilities registry methods I’ve tried as successfully edited that part of the registry running in Vista 64.


#4

You need admin rights to edit registry entry.


#5

Are you writing a 32 bit app or 64 bit app? You may be running into 64 bit registry reflection.


#6

Its a 32bit app and I’m hoping for reflection in 64bit. Currently I’m not seeing any changes even in the WOW64Node. The reasons that i ask is that in the Juce documentation it clearly state these methods only work with win32 currently.


#7

So you tried running it with admin privileges?


#8

It seems if i manually right click and run the app as administrator it will write to the registry. This presents a problem for me though since I’m adding a run at startup line dynamically. Does anyone know how to get an app to run with administrator privileges by default with out input from the user?


#9

Good luck with that! If you find a solution, there are probably quite a few virus writers out there who’d be interested to hear about it!


#10

there has to be some way to do it or at least write to the registry with out needed to run in admin. Yahoo Messenger does this with out causing Vista to do model dialog backflips.


#11

Try writing to HKEY_CURRENT_USER instead.


#12

Yep that is what i needed to know thanks Matt!