Repeatable crash Live coding Windows


#1

Hi, link to vid attached.


#2

Hi leehu, thanks for reporting this issue and even screencasting the behavior! As I cannot reproduce it directly, please let me ask for a few details. It’s sufficient to get the first “No” :slight_smile:

Did you run a Projucer that you built from source yourself?
Did you run a release build?
Did you build it from the 4.2.4-tagged JUCE revision?
Can you also reproduce it with the prebuilt Projucer version from the released zip?
Can you reproduce it with any project?

If your answer is yes for all above points, may I ask you to share the project you can reproduce it with.

Thank you very much! Looking forward to fixing this for you.


#3

Did you run a Projucer that you built from source yourself?
– Yes
Did you run a release build?
– Happens in both
Did you build it from the 4.2.4-tagged JUCE revision?
– Built from the develop branch so I could access the Live coding on Windows
Can you also reproduce it with the prebuilt Projucer version from the released zip?
– Not tried, but can try over the weekend
Can you reproduce it with any project?
– Can try some other projects over the weekend


#4

Ok thanks for the fast reply, checking it now


#5

Hi leehu, no success yet for reproducing your issue… I’d really like to nail this down though!

Did you build it from the 4.2.4-tagged JUCE revision?
– Built from the develop branch so I could access the Live coding on Windows

Please note that Live coding on Windows is already enabled on 4.2.4-tagged master

Can you also reproduce it with the prebuilt Projucer version from the released zip?
– Not tried, but can try over the weekend

That would be very useful to know in order to isolate the issue

Can you reproduce it with any project?
– Can try some other projects over the weekend

Especially if it’s reproducible with any of the demo projects, that would help a lot


#6

Hi, didn’t have chance to look into this further over the weekend but will do in a couple of days - I’ll try building the 4.2.4-tagger master and see if that has the same issues and try some of the demo projects. thx


#7

Hi, just looking into this again but when I do a ‘git checkout 4.2.4’ it tells me I’m in a detached head and git pull requires more info - I’m not really familiar enough with git to understand what this means so going to have to do a bit more research…


#8

I’ve built code from master and from the 4.2.4 detached head and neither of those give me live coding options.