Request: rename the "JUCE_DEBUGxxx" check


#1

Jules,

in your PT wrapper class you use a check to see if it should link the debug or release versions of the PT libs:

 #if JUCE_DEBUGxxx // (the debug lib in the 8.0 SDK fails to link, so we'll stick to the release one...)

could you rename this to something a bit less generic? That way I can actually define this preprocessor define in the introjucer. If everything is working I will shortly make a post concerning building RTAS under vs2008 (with a LOT of help from Olivier Tristan). And, with my build settings, linking with the debug libs (again, vs2008!!) works just fine. Debugging still doesn’t work for me but at least the building already works.

  • bram

#2

Wow, yes - sorry, that code looks like I must have been testing something and left it in there by mistake - I wouldn’t normally use a name like that! I’ve changed it now to a more sensible JUCE_RTAS_LINK_TO_DEBUG_LIB, thanks!


#3

Also check out this thread where this is discussed:

http://www.rawmaterialsoftware.com/viewtopic.php?f=8&t=11438

Rail


#4

And actually even better, that xxx should just be removed:
http://www.rawmaterialsoftware.com/viewtopic.php?f=8&t=11750

  • bram

#5

Ok… so the consensus is that JUCE_DEBUG is the way to go? I can leave JUCE_RTAS_LINK_TO_DEBUG_LIB in there as a flag that can be overridden if anyone has problems.


#6

JUCE_DEBUG is cool as long as the PlugInLib.lib is built as stdcall. It wouldn’t hurt to have JUCE_RTAS_LINK_TO_DEBUG_LIB but I don’t think it’s necessary. Perhaps a comment in the code to remind the user to build stdcall versions of the libraries (which is not the default).

Cheers,

Rail


#7

Shouldn’t the override flag then be DON’T use the debug rtas libs in any case?

If juce_debug and !dont_use_debug_libs

Or rather a flag that forces the usage of the release libs even in debug…?

  • bram

#8

If we’re in debug mode, and if the user hasn’t specified a preference, then use the debug library… That’s what I intended it to do, and it seems correct to me… (?)

(I have just got back from a weekend away at a festival though, and my brain isn’t fully in gear yet, so let me know if I’m being stupid!)


#9

Yes, it’s correct as you initially intended… The only issue was that the PluginLib defaulted to building as cdecl which caused the problem.

Rail