RTAS plugin. The PT nightmare


#1

Hi all,

My project is not loading in Pro Tools and I don’t know why. I tried to launch PT in command line and see that it tries to load the plug because I see the
Juce v1.46 printf in the console. Unfortunately, PT does not show any message to diagnostic the problem.

Does anyone a way to validate a RTAS plugin (like the auval tool for AU)?
Otherwise, do you know a way to launch PT with xcode debugger?

Thanks in advance
Kevin


#2

I’ve never found a way to debug PT… When I get stuck like this I normally make it dump a lot of debugging to a log file so I can figure out how far it’s getting.


#3

Works fine here.

You only needs a debug build of Protools(see this with Digi dev services) and use attach instead of launching it directly.

Does your plugin export the correct function:
NewMachOPlugIn CloseMachOPlugIn and _PI_GetRoutineDescriptor

If your plugin is not seen at all then it’s a bit harder to do and logging is your only way.

HTH


#4

Thanks for your answer. I’ll try in that way.


#5

So I’ve found a debug version of PT and now I am able to break in the code.
That is a big step. :smiley:
Now I have don’t find what is the problem because all seems to be ok when I run step by step.

Thks again


#6

I finally got it.
The problem was that it was not the target of my project which was based on the CommonDebugSettings.xcconfig given by the PT_SDK but the whole project.

I don’t know what it changes but it was the source of my pb.