[SOLVED]Any idea how to solve this problem?


#1

Hi guys,

I am new to android studio juce-based projects and when i tried to run the " hello world " example tutorial of android studio the following error occurred :

The currently selected variant "armeabi-v7a-debug" uses split APKs, but none of the 1 split apks are compatible with the current device with density "-1" and ABIs "x86". "

Does anyone know what is the problem that I am facing here ? How can I solve this error ?

Thanks.

***I SOLVED THIS PROBLEM. I JUST SHOULD HAVE CHANGED BUILD VARIANTS.


#2

hello, Could you explain how you did that??
I am facing the same problems and can't run my project in android...it is just a button to make it simple

 

Regards

 

Carlos


#3

Check out Timur's Android Studio guide. Under 3 you will find how to change build variants. The architecture must match the device you are trying to run it on. For example, the Android Studio emulator will want an x86 built variant.