[Solved] Unable to type in TextEditor despite set setReadOnly(false)

Hey All,
I recenly started working in a very large code base and the GUI is based in JUCE. I have been tasked with implmenting a new feature that requires a TextEditor box the user can type into. However after creating one it is not editable. Even after using setReadOnly() to set it to not read only (which is normally the default behavior). Is there some sort of global parameter that could be overwriting this that I am not aware of? Has anyone ran into this problem before?

Very unusual. Does your TextEditor receive focus normally? Do you see the caret blinking? If not, could it be that you have another transparent Component above it, that’s preventing you to interact with it using the mouse? Are you able to give the TextEditor the focus using the TAB key?

There was no caret and after a lot of searching I did discover that there was another component intercepting the mouseClicks. Was trying to mark this as solved but couldn’t figure out how to edit my post