[SOLVED] Xcode AVPlayerView compilation issue on latest tip


#1

Bit at a loss for this one - the only source of the problem I can see is that we have the video module included in our app.

Any tips appreciated!


#2

resave your project with the latest projucer!


#3

Well, I did, but I’ll delete the project files and regenerate them to be sure.


#5

Right, so with everything cleaned out and starting fresh, I still run into this issue.

After some playing around, it appears that if the OSX Architecture is set to 32-bit or 32/64-bit, the linker error happens. With 64-bit Intel, it links.

This doesn’t work for us, as we need to target 32-bit along with 64-bit.


#6

Running into this issue also.


#7

Ah, it seems that the AVPlayerView class isn’t available for older SDK targets in 32-bit builds… We’ll have to try to find either a different class that works for older targets, or conditionally bring back the crappy old deprecated Quicktime implementation for 32 bit builds…


#8

What deployment target does it start to fail with?


#9

Any deployment target will cause the build to fail if 32-bit or 32-bit/64-bit are selected. (Even setting it to 10.12 fails to link!)

I’m already aware that AVPlayer’s min SDK is 10.7 on macOS, so my deployment target is set to 10.7.


#10

It’s this class:
https://developer.apple.com/documentation/avkit/avplayerview
10.9 onwards


#11

Okay, that’s fine I’ll set it to 10.9. Either way, the issue is still present.


#12

Yep, just as I thought. I’d just kicked off a build on the server and it’s failed due to targeting 10.8. I think we can safely bump this to 10.9 though…


#13

Joel’s, right, it doesn’t look like it compiles on any 32-bit target (even 10.12)!


#14

Didn’t realise I was on Mythbusters but I’ll take it!


#15

I just ran into this issue with osx 10.9 and juce 5.3.1.
This post is marked as solved but what was the solution for this?