Standalone plugin crashes on opening Audio and MIDI setup (Linux)


#1

Hi everyone!

I just started to learn JUCE, compiled latest release, and created a basic plugin project. When I try to run it as standalone, the program crashes somewhere in the ALSA‘s MIDI-related routines when I open audio settings. Does anyone know what causes this? Maybe I missed some configuration in the project to avoid this?

Eugene


#2

It looks like snd_seq_open on line 262 fails to open a default MIDI device and as a result handle is nullptr. Do you have any logs printing any errors that could shed some more light? Perhaps something else is using the device?


#3

OK, I ran the program with everything that could possibly use audio disabled, but it segfaults nevertheless. Actually, I don’t have any MIDI devices on the laptop.


#4

I just opened Renoise which complained about ALSA MIDI, but also suggested to check the snd-seq kernel module. Will check this later.


#5

It worked after reboot… Probably I forgot to do this after a system update few days ago.


#6

ok,it’s good to hear!