Strange debugging callstack


#1

i’m experiencing some strange behaviours when debugging applications. don’t know why, i’m launching the debug, and breaking at the exe entry main function. as you could see in the image, the application is not starting as usual from maincrt startup and such. instead there are some calls (changing partially every time i relaunch debugging) before, and this is not blocking the application but i would like to know if this is normal and if anyone have experienced this before, as far as i know i haven’t seen anything like this before… i’ve tried rebuilding the whole solution, but none. maybe i have to reinstall the vs express ide ?

image


#2

If you look closely, it says “frames below this point may be incorrect”… which they clearly are. The debugger just sometimes does that, I’m not sure why. It’s not something to worry about though.


#3

ok jules, thanx. i had fear that i have corrupted something (especially my project) since i haven’t seen this before. from the time i see this i’m experiencing some strange stuff… dunnow if this is related, but i’m having problems doing:

File SomeObject::getFile ()
{
return filePath; // here is crashing in File copy
// constructor if filePath == File::nonexistent
}

// …

File f (“someGoodPath”);
if (f == theObject.getFile())

with getFile() returning File::nonexistent …
what the hell is going on there… this worked yesterday… s**t…


#4