SystemStats::getUniqueDeviceID() returning empty String

Hi folks,

I’m getting the jassert that says “Please tell someone at JUCE if this occurs”.

I read in this post that @oli1 worked on this.

We tried this on M1 Mac Book Pro, and usually works well. Occasionally we hit this assert, and after restarting the computer, works again.

Open to help if you need any other info.

Have a nice day!

Yep, that one is mine.

I was unable to repro this on my M1 or M2 Mac, I was able to get “ioreg” to fail if I disabled the static key and thrashed it hard enough with 4 threads. I’m not 100% sure this is what you’re seeing but it’s impossible to rule out.

I’ve re-implemented it using an older API, it appears to be a bit more resilient and it results in the same ID generated. I will pass it up through the MR chain now.

How often would you see this jassert hit?

Very unlikely to happen. We use it in the constructor of our project, every day on 6 computers. Only happened 2 times, in 2 different computers. But until we rebooted those, they keep returning empty strings.