Timer call back in juce 1.50


#1

Hi Jules,

I was extensively using Timer for my application with juce 1.46,
as I moved my application to juce 1.50 I’m not getting any timer callbacks.

Any clue why this would happen?

Thanks in advance.


#2

…no, no clue at all. Timers are working just fine. When you say 1.50, do you mean the tip? If not, please try that first!


#3

Hi All,

When I build my application in release mode the callbacks are working fine, but it still doesn’t work in debug mode.
Can anybody tell me what could be wrong?

Thank you!


#4

Have you tried common-sense stuff like

  • running the juce demo to check that timers are working in other projects
  • debugging into the code that registers the timers and delivers the timer callbacks
  • writing a very simple test case class that does nothing but runs a timer, and see if that works

#5

Hi xeric,
While you are at it. try removing all the libraries from dependencies list and clear framework search path field in the project settings. Add the libraries again. And try clean building.

The only time I have faced such issue(Working in release but not debug) was when i added juce release and juce debug library to my release target.


#6