Hi, I found a typo in variable names in SetProperty function / case kAudioUnitProperty_OfflineRender (starting on line 660) in file:
shouldBeRealtime should be named shouldBeNonRealtime
isCurrentlyRealtime should be isCurrentlyNonRealtime
Both variables are related to offline state which is non realtime.
line 726 for exactly name isCurrentlyNonRealtime used in same context