Undeclared kAudioUnitProperty_NickName in AUBase.cpp


#1

probably needs some #if (MAC_OS_X_VERSION_MIN_REQUIRED > MAC_OS_X_VERSION_10_8) around


#2

It's an Apple file, not a JUCE one.. Are you building for 10.6? If so, is that the only change needed to make it work?


#3

> It's an Apple file, not a JUCE one.

yes I know, but you included it in juce_audio_plugin_client! (so right now, JuceDemoPlugin won't build)

This change seems enough to make it work


#4

Thanks, but is it 10.6 that you're using, or 10.7?

We've had some reports that this doesn't work in 10.6, but are none of us here can find a 10.6 machine to test it... It'd be really helpful if someone using 10.6 could let us know what's needed to fix this!

And presumably a better fix would actually be for us to add a define for kAudioUnitProperty_NickName, e.g.

enum { kAudioUnitProperty_NickName = 54 };

?


#5

ah, no, I'm not on 10.6 sorry


#6

I’m seeing the same in Xcode 5.1.1 and OSX 10.8.5

Perhaps there’s a newer version of AudioUnitProperties.h where it’s added to the enum already? The version of AU I had kAudioUnitProperty_NickName wasn’t used.

A Google search led to this:

where it’s equal to 54.

Rail


#7

Yes, it's defined in later versions of the framework, that's not the problem.

My question is to people who are still trying to build against older pre-10.8 versions of CoreAudio: in order to get it all to build, is it sufficient for us to add just that one symbol definition, or are there other errors too?


#8

I created a new test plugin using IJ in 10.8.5 and it compiled fine once I added the definition to AudioUnitProperties.h using a base SDK of 10.7 and there were no errors.

I also tested on the old Mac Pro running 10.7.5 and Xcode 4.6.3 and it built without errors.

Rail


#9

Ok, thanks for the info!

I'll add that definition, and I guess if anyone else is using even older versions then they'll let us know!


#10

Using a base SDK 10.6 does generate errors though…

Right click and open the image in a new tab to enlarge.

Rail


#11

Maybe stupid question, why you are using such an old base SDK? Why not using the latest SDK, with OSX compatibilty version 10.6 ?


#12

Because Jules asked me to test it.

I usually use 10.7 which is required for RTAS

Rail


#13

The general sentiment here at juce HQ is that supporting 10.6 is crazy these days, and that even if you do, you should use a later SDK with backwards compatibility mode. But I know there are still people out there who for whatever reason insist on using the 10.6 SDK <sigh..>


#14

Agreed… You can’t even target anything lower than 10.7 if you use the C++11 std lib. (libc++)

Rail


#15

Sean asked "What OS are you using in late 2014?" on kvr last december : http://www.kvraudio.com/forum/viewtopic.php?p=5960770

I thought it was interesting.